Jump to content

Excessive FPS rendering in Sims 3

Elf Prince

Recommended Posts


by Carlos on Wed 25 Nov 2015, 05:18


This small introduction will be about "FPS" in Sims 3 and why it can be important. "Frames per second" (or FPS) describes the number of images that are displayed consecutively, and in one second. The term is used in areas such movie making/filming, video broadcasting and in computer graphics. The average computer will be capable of rendering (i.e. "keeping up with") refresh rates of about 60 FPS; more modern and higher-end machines may be capable of doing a bit more. 

Now, a piece of software might be running at more frames per second than your computer is capable of keeping up with.

Regarding The Sims 3 it is possible that for some users, the refresh rates can become dangerously high, possibly leading to screen distortions, game crashing/freezing, computer shutdowns or even hardware damage. See this example here from my own computer (I only made this screenshot for illustration purposes):


It's not easily visible, but in the top left corner, you can see the number "218". This refers to the frames per second, and was recorded using Razer's GameBooster. This number is ridiculous and should not be that high. There can be cases however, in which the frame rates of players can be even higher than that.

Unlike many other modern games, The Sims 3 does not come with a (proper and functioning) system of synchronizing the frames of the game, to match your system's capabilities. For the majority of players in Sims 3, the following part of the options-menu will probably be the default setting:


"Enable Fullscreen mode" marked + the "Screen Refresh rate" with whatever setting is available in your cases. But that doesn't seem to do much to address the issue I described above. It is still possible that despite these settings, the game will attempt to render many more FPS, than your computer is capable of doing under normal circumstances. So what to do now ?

1) As I myself have an NVIDIA graphics card, I can use an option in the NVIDIA control panel to "force" the game to use a certain number of FPS. If you also have an NVIDIA graphics card, right-click on the desktop and select NVIDIA Control Panel.


On the left, click on "Manage 3D settings". Under select a program to customize, choose the TS3W.exe. If it doesn't seem to show up for you, try creating another desktop shortcut to the TS3W.exe, by using the "add"-button in the NVIDIA Control Panel, right next to Sims 3 in my screenshot. The file will be typically located in C:\Program files(x86)\Electronic Arts\The Sims 3\Game\Bin. Or C:\Program files(x86)\Origin Games\The Sims 3\Game\Bin, if you have it on Origin.

Back to the NVIDIA Control Panel, scroll down a bit until you see the "Vertical Sync" option. Unfold the drop-down menu by clicking the symbol in the right. Choose ON from the drop down menu. I have not tested the other options which could work too, like "Adaptive" and "Adaptive half refresh rate", but choosing "On" should do the trick in most (if not all) cases.

This procedure will synchronize the frame rate of the game, with the frame rate of your computer/screen. And should hopefully help solve some issues with crashes/lags/freezes/shutdowns and whatnot.

Tip: as this problem with the excessive frame rendering can occur in a number of other games too (for example The Sims Medieval), it might be helpful to configure the V-sync setting "globally". See this here:


If you turn on V-Sync "globally" in the NVIDIA control panel, then this setting will be applied to ALL your installed applications. So by default, V-Sync will be turned ON for all apps. You could then of course make exceptions, by going to the next tab, and configure individual settings for certain programs.

2) For those of you having AMD graphics cards, try the following. Right-click on the desktop and select "Catalyst Control Center". Navigate to Gaming -> 3D application settings. You could also type "vertical" in the search box in the top left. You should get here:


Scroll down to "wait for vertical refresh", and push the slider all the way to the right. Click on "Apply" at the bottom of the window to save the settings. 

Keep in mind that these "vertical sync" tweaks will only work if you play the game in fullscreen mode ! Another alternative could be for you to go without these graphics card tweaks, and then playing the game in windowed mode. Just unmark the box named "Enable Fullscreen mode" in the options menu, and confirm the setting.

In my case, after applying the setting shown in the NVIDIA Control Panel, the FPS never went higher than 60, in-game. Some might ask now if third-party frame limiters can help here too, but I have not looked into that yet.


  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
Click here for more!

  • Create New...